Fixmygps Mk III - GPS Navigation Made Easy
iGO8 "program database cannot be found" - Printable Version

+- Fixmygps Mk III - GPS Navigation Made Easy (http://fixmygps.info/forum)
+-- Forum: GPS Programs (/forumdisplay.php?fid=11)
+--- Forum: GPS's (/forumdisplay.php?fid=58)
+---- Forum: GPS DVD TV CD Radio Single & Double Din Units (/forumdisplay.php?fid=62)
+---- Thread: iGO8 "program database cannot be found" (/showthread.php?tid=2263)

Pages: 1 2


iGO8 "program database cannot be found" - ulyssy - 09-11-2011 08:27 PM

rakkaone187 Wrote:Ulyssy,

My name is David and I am new to iGO8. Just as the other new users of a Double Din Chinese GPS 6.5'' DVD Head Unit I am having problems. My Chinese unit is made from flyaudio.net website You are not allowed to view links. Register or Login to view.

Its a 2DIN, WinCE 5.0 that supports miniSD card insert. I have the original miniSD card with original files of iGO8 and extra files that will add larger resolution screen size to 800x480. *The files are seperate. I've seen many posts for the correct sys.txt as most people on the internet are not fully knowledgeble with sys.txt files.

To start with, a couple of questions.

That "original" SD card, did that come with the device, and with that inserted, did you have a working iGO8, on your unit?

If that did not come with the unit, then where did you get it from, and what is the full version number of iGO8 on it. (To read the version number of "igo8.exe", from a SD, place the SD into a card reader connected to your PC, browse to "igo8.exe", right click on it and choose "Properties". Click on "Version" tab and choose "Product Version" under "Item Name". Read the full version number under "Value")

What are these "extra files" and where did these come from? Is there another "igo8.exe", amongst them?

Can you post the folders/files structure of both the "original" SD and the "extra files". Also the contents of the "sys.txt" file(s) that exist there.

==Computers_comp26==


RE: iGO8 "program database cannot be found" - nabi - 10-11-2011 05:13 AM

From my Tutorial on NaviTotal:
Quote:The program database error message is exactly what it says. iGO8's program looks for its proprietary folder where it expects to find everything necessary to run and compile the program. But, in the case of this error doesn't.

Most likely you are trying to run iGo off an SD card. I have no information about what you have done before and how. I presume your iGO8 program is on an SD card and that it is complete with assumption that the directory and physical structure are okay. And I also suppose you start iGO by shortcut (or other means) on your device.

Possible errors you can check:

1. You must have a file called iGO.exe. If there is a file called application.dat, rename it into iGO.exe.

2. Next open the sys.txt file which in the iGO8 root directory (a simple text editor like Notepad will do). Probably you will see some lines like this.:

[folders]
app="%SDCARD%/iGO8"

If these lines are not there, goto step 3.

Change the second line so that it looks like this:

;app="%SDCARD%/iGO8"

Notice the ;. The ";" makes the line not used or computed (a rem statement in computer programming language). While the program is running, iGO8 checks the directory it's in. So this should work.

3. If it doesn't work (or the line doesn't exist), Then your sys.txt should contain the lines, make sure it does. (without the ";" !!!!! )

Now it gets a bit complicated. But it's not my fault luckily.
app="%SDCARD%/iGO8" tells the program the path to the folder where your iGO8 is located or found. Using that line as an example, you must discover yourself what it should look like. Therefore use an explorer program (best the one on your device - you should find the name of the SD card given by the device) and write down the path. Either write it down, copy the name into computer memory and get ready to enter the line in your sys.txt file.

For example, this is how the lines for a Samsung Omnia would look:

[folders]
app="My Storage/Program Files/iGO8"


Other examples:

[folders]
app="SDCard_dsk_num=3"


[folders]
app="SDCard_dsk_num=7"




4. Finally one more comment.
On some devices (do not ask me why or which devices - it's probably caused by the windows version or in what way windows is adapted by the manufacturer) iGO only starts when the "%" signs are no part of the app="%SDCARD%/iGO8" command line. Example:

[folders]
app="SDCARD/iGO8"


This is how ronp76, former mod, explains the very same thing:
(Thank you Ron!)
Presently I run only iGO8 off an SD card but will try to help. I assume that your in car DVD GPS has a menu based system that allows you to run various programs. I further assume that you it has a button to run TomTom.

More than likely each of these software buttons are tied to a script file which looks like XXXX.mscr (mscr is the script file extension name and XXXX can be iGO8, TomTom, etc.). In order for the GPS to execute or run the script and associated software, it needs to know the exact name, drive and directory of each program. Unfortunately, these names can vary from one manufacturer to another.

Your GPS hard drive (HD) can be called either MyFlash or ResidentFlash which are two of the more common names. The SD card can be called StorageCard, Storage_Card or SDMMC. The only way to find out exactly what your GPS calls itself and the card is to download the file attached to this reply.

Copy this file called CECommander (CECMD.exe) to your SD card (You are not allowed to view links. Register or Login to view. and then run it from your car GPS.

I also assume that you can run or execute files on the SD card. When run, CECMD.exe is like Windows Explorer. It will tell you what the exact name of your what your system sees the GPS hard drive (HD) as and also the name of SD card. You need these exact names because that is what GPS will look for.

For example, when I run CECMD.exe, I see:

My Documents (folder)
Network (network folder)
Program Files (folder)
ResidentFlash (hard drive symbol)
SDMMC (hard drive symbol)
Temp (folder)
Windows (folder)
Control Panel.lnk (shortcut link)
iGO8 (folder)

On the SDMMC (SD card) I see just an iGO8 folder which is all I have set up.

The next part is complicated and involves being able to have the direct instructions (from either the manufacturer, seller or another user). Most likely your GPS runs its software off "button" that are linked by script files (.MSCR file extensions) to programs on an SD card.

Can you hook up your in car GPS to a computer via a USB connection? If you can then you will need to look for .MSCR files, copy them to your computer and then tell me what you see. Good luck.
_______________________________


Another thing to explain here.

Depending on the device, it is possible you need to change the name of the iGO directory and the igo.exe file.

like this (thanks Bobtheboor!)
Had to make a directory called DestinatorApps then change the name of directory iGO8 to Destinator. Then changed file application.dat to Destinator.exe.

and change the sys.txt to meet these changes :

[folders]
app="%SDCARD%/DestinatorApps\Destinator"
Of course , the name to change to depends on the device.

If you have to make changes to the device's shell.ini (to start igo the same way as your previous gps program) is not part of this post



RE: iGO8 "program database cannot be found" - nabi - 11-11-2011 12:27 AM

Another interesting topic on Navitotal (depending on your device) is this one : You are not allowed to view links. Register or Login to view.

I only post the link so I do not lose the images.

The post is originally from yoff.


RE: iGO8 "program database cannot be found" - bazzle01 - 11-11-2011 11:04 AM

If you are from Oz try one of my complete iGO downloads?

Bazzle


RE: iGO8 "program database cannot be found" - amogranato - 09-08-2013 01:39 AM

Hello,

I have a IOKONE AST-DVW876 navigation with Windows CE 6.0 installed. I get the following error : "The application failed to start last time...etc". I tried to change the sys file based on what I read on this forum but it shows "program application database cannot be found". And sometimes it just restarts over and over again...depending on what changes I make to the sys file. You can see below the lines I have in the sys.
I am leaving on holiday soon and I really need it to work. So a fast reply would be highly appreciated.

Thanks in advance.
This is the original form of the sys file:
[attachment=1108]
;[device]

[folders]
app="My Storage/iGO8"

[interface]
maxzoom2d=6000000
show_exit=1


RE: iGO8 "program database cannot be found" - NRT - 09-08-2013 08:03 AM

Might be looking for the content folder, can't see it listed.


RE: iGO8 "program database cannot be found" - pablo66 - 03-03-2015 04:24 PM

Hi Im in OZ
Can you please supply link to igo8 software
Cheers
Paul


RE: iGO8 "program database cannot be found" - bazzle01 - 04-03-2015 09:50 AM

Paul

igo8 or Primo?
Plenty of links for Primo Oz . Chas521 for igo8


RE: iGO8 "program database cannot be found" - mdah15 - 30-07-2015 06:00 AM

Re-named the files but still nothing coming up on the navigation software.


RE: iGO8 "program database cannot be found" - Sesel - 25-12-2015 01:02 PM

(09-08-2013 01:39 AM)amogranato Wrote: You are not allowed to view links. Register or Login to view.Hello,

I have a IOKONE AST-DVW876 navigation with Windows CE 6.0 installed. I get the following error : "The application failed to start last time...etc". I tried to change the sys file based on what I read on this forum but it shows "program application database cannot be found". And sometimes it just restarts over and over again...depending on what changes I make to the sys file. You can see below the lines I have in the sys.
I am leaving on holiday soon and I really need it to work. So a fast reply would be highly appreciated.

Thanks in advance.
This is the original form of the sys file:

;[device]

[folders]
app="My Storage/iGO8"

[interface]
maxzoom2d=6000000
show_exit=1
Hi ,have u sorted out this issue? I have extrons for Zafira B,and the original sd card corrupted just the second day,I got a copy from friend who had Igo on gps device, it runs for 2 days and 3rd day I have to insert and remove to run it, now even if I do that It won't run it gives me either above msg or another 2 msg which is,user interfere caused ...or failed to start reset,and evwn with reset it won't work.. :( thanks

Sent from my SM-T210 using Tapatalk


RE: iGO8 "program database cannot be found" - Jards88 - 25-12-2015 05:08 PM

Comment out or remove this line from sys.txt.
app="My Storage/iGO8"

This causes more grief than any other setting that I am aware of. As I've said many times before, iGO or Primo is smart enough to figure out where it has been started from and find all it's data. The app= setting is normally only required for some non standard installations.

Cheers, Ian


RE: iGO8 "program database cannot be found" - benno - 24-03-2016 06:06 AM

i have a lelec radio i need help with..anyone..............
Lelec Indash 7" Inch 2Din Touch Screen Radio Stereo Wince Bluetooth BT TV iPod 3D Subwoofer SD/USB Car Vehicle Steering Wheel Control DVD Player+Water


RE: iGO8 "program database cannot be found" - nabi - 24-03-2016 08:37 AM

Very cryptic.
Also you sent me PM with these exact words:
benno Wrote:Lelec Indash 7" Inch 2Din Touch Screen Radio Stereo Wince Bluetooth BT TV iPod 3D Subwoofer SD/USB Car Vehicle Steering Wheel Control DVD Player+Water

I wondered if you were buying or selling. Do you know why I wondered?

Your post isn't informative either. Seen the thread title and considering that may be what happens to you, thus the reason you seek help: did you read the thread? Only 12 posts. Solution may be one of those 12. Maybe then your problem is solved when you apply correctly.
In addition, you could also delete the save folder and see if that helps.


RE: iGO8 "program database cannot be found" - nabi - 04-04-2016 07:23 AM

benno Wrote:i bought it and need help.......i need to know if there is a secret menu and how to access it plus if there is any firmware to upgrade this radio..was suppose to get gps software and cant do nuttin or send it back..this radio has no name



RE: iGO8 "program database cannot be found" - köşegen - 28-04-2016 10:56 PM

SOVED !!!!
Open sys.txt with notepad

Old [folders] code is deleting or editing .Write to has_secondary_root=0

SYS.TXT
______________
[folders]
has_secondary_root=0


save and run